]> git.pld-linux.org Git - packages/perl-HTML-Form.git/blob - perl-HTML-Form.spec
50346d6f3f2be5dc18b611017d247c56855282c9
[packages/perl-HTML-Form.git] / perl-HTML-Form.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    HTML
6 %define         pnam    Form
7 Summary:        HTML::Form - Class that represents an HTML form element
8 Summary(pl.UTF-8):      HTML::Form - klasa reprezentująca formularz HTML
9 Name:           perl-HTML-Form
10 Version:        6.05
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ffca33c801449e33b436216741273b2c
17 URL:            http://search.cpan.org/dist/HTML-Form/
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Encode >= 2
22 BuildRequires:  perl-HTML-Parser
23 BuildRequires:  perl-HTTP-Message >= 6
24 BuildRequires:  perl-URI >= 1.10
25 %endif
26 Requires:       perl-Encode >= 2
27 Requires:       perl-HTML-Parser
28 Requires:       perl-URI >= 1.10
29 Conflicts:      perl-libwww < 6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Objects of the HTML::Form class represents a single HTML
35 <form>...</form> instance. A form consists of a sequence of inputs
36 that usually have names, and which can take on various values. The
37 state of a form can be tweaked and it can then be asked to provide
38 HTTP::Request objects that can be passed to the request() method of
39 LWP::UserAgent.
40
41 %description -l pl.UTF-8
42 Obiekt klasy HTML::Form reprezentuje pojedynczą instancję formularza
43 HTML (<form>...</form>). Formularz składa się z ciągu pól
44 wprowadzania, zwykle mających swoje nazwy i mogących przyjmować
45 różne wartości. Stan formularza może być zmieniany i po przekazaniu
46 obiektów HTTP::Request może być przekazany do metody request()
47 klasy LWP::UserAgent.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/HTML/Form.pm
72 %{_mandir}/man3/HTML::Form.3pm*
This page took 0.225731 seconds and 2 git commands to generate.