]> git.pld-linux.org Git - packages/perl-HTML-Form.git/blob - perl-HTML-Form.spec
1f77bf6cd51d2ddb1bb13b937c6ad06bc31719d7
[packages/perl-HTML-Form.git] / perl-HTML-Form.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    HTML
6 %define         pnam    Form
7 Summary:        HTML::Form - Class that represents an HTML form element
8 Summary(pl.UTF-8):      HTML::Form - klasa reprezentująca formularz HTML
9 Name:           perl-HTML-Form
10 Version:        6.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  db4c22cf711016e0f6d8ef6a8831ca8e
17 URL:            https://metacpan.org/release/HTML-Form
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Encode >= 2
23 BuildRequires:  perl-HTML-Parser
24 BuildRequires:  perl-HTTP-Message >= 6
25 BuildRequires:  perl-URI >= 1.10
26 %endif
27 Requires:       perl-Encode >= 2
28 Requires:       perl-HTML-Parser
29 Requires:       perl-URI >= 1.10
30 Conflicts:      perl-libwww < 6
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Objects of the HTML::Form class represents a single HTML
36 <form>...</form> instance. A form consists of a sequence of inputs
37 that usually have names, and which can take on various values. The
38 state of a form can be tweaked and it can then be asked to provide
39 HTTP::Request objects that can be passed to the request() method of
40 LWP::UserAgent.
41
42 %description -l pl.UTF-8
43 Obiekt klasy HTML::Form reprezentuje pojedynczą instancję formularza
44 HTML (<form>...</form>). Formularz składa się z ciągu pól
45 wprowadzania, zwykle mających swoje nazwy i mogących przyjmować
46 różne wartości. Stan formularza może być zmieniany i po przekazaniu
47 obiektów HTTP::Request może być przekazany do metody request()
48 klasy LWP::UserAgent.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes
72 %{perl_vendorlib}/HTML/Form.pm
73 %{_mandir}/man3/HTML::Form.3pm*
This page took 0.040682 seconds and 2 git commands to generate.