]> git.pld-linux.org Git - packages/perl-HTML-Clean.git/blob - perl-HTML-Clean.spec
e954e0f2c058b02138405bbadcce033fec781ec8
[packages/perl-HTML-Clean.git] / perl-HTML-Clean.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    HTML
7 %define         pnam    Clean
8 Summary:        HTML::Clean - cleans up HTML code for web browsers, not humans
9 Summary(pl.UTF-8):      HTML::Clean - czyści kod w HTML-u z punktu widzenia serwerów WWW
10 Name:           perl-HTML-Clean
11 Version:        0.8
12 Release:        10
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ee562703b7700c7fd4173f355e83ec2c
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The HTML::Clean Perl module encapsulates a number of common techniques
25 for minimizing the size of HTML files.  You can typically save between
26 10% and 50% of the size of a HTML file using these methods.
27
28 %description -l pl.UTF-8
29 Moduł Perla HTML::Clean zamyka w sobie kilka ogólnych technik
30 minimalizacji rozmiaru plików HTML. Zazwyczaj pozwala on zaoszczędzić
31 na rozmiarze pliku HTML od 10% do 50%. 
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README TODO
55 %attr(755,root,root) %{_bindir}/*
56 %{perl_vendorlib}/HTML/*.pm
57 %dir %{perl_vendorlib}/auto/HTML
58 %dir %{perl_vendorlib}/auto/HTML/Clean
59 %{perl_vendorlib}/auto/HTML/Clean/autosplit.ix
60 %{_mandir}/man[13]/*
This page took 0.047817 seconds and 2 git commands to generate.