]> git.pld-linux.org Git - packages/perl-HTML-CalendarMonth.git/blob - perl-HTML-CalendarMonth.spec
use generic url
[packages/perl-HTML-CalendarMonth.git] / perl-HTML-CalendarMonth.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    HTML
6 %define         pnam    CalendarMonth
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        HTML::CalendarMonth - generating and manipulating HTML calendar months
9 Summary(pl.UTF-8):      HTML::CalendarMonth - generowanie i obrabianie miesięcznych kalendarzy w HTML
10 Name:           perl-HTML-CalendarMonth
11 Version:        1.26
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5b633b20139e21fc161e053038a9c161
18 URL:            http://search.cpan.org/dist/HTML-CalendarMonth/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Accessor
23 BuildRequires:  perl-Date-Calc
24 BuildRequires:  perl-Date-Manip
25 BuildRequires:  perl-DateTime-Locale
26 BuildRequires:  perl-HTML-Element-Extended >= 1.18
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 HTML::CalendarMonth is a module that simplifies the rendering of a
33 calendar month in HTML. It is NOT a scheduling system.
34
35 Calendars are represented as HTML::Element based structures, derived
36 from the HTML::ElementTable class.
37
38 The module includes support for 'week of the year' numbering,
39 arbitrary 1st day of the week definitions, and aliasing so that you
40 can express any element in any language HTML can handle.
41
42 If you wish to use 'week of the year' numbering, or want to explore
43 dates beyond the capability of the internal Perl time functions, then
44 you will need Date::Calc or Date::Manip.
45
46 %description -l pl.UTF-8
47 HTML::CalendarMonth to moduł upraszczający renderowanie miesięcznych
48 kalendarzy w HTML-u. To NIE jest jest system planowania.
49
50 Kalendarze są reprezentowane jako struktury HTML::Element,
51 wyprowadzone z klasy HTML::ElementTable.
52
53 Moduł obsługuje numerowanie tygodni w roku, dowolne definicje
54 pierwszego dnia tygodnia oraz aliasy, co pozwala na wyrażanie
55 dowolnego elementu w dowolnym języku, jaki może obsłużyć HTML.
56
57 Do numerowania tygodni w roku albo obsługi dat spoza zakresu
58 obsługiwanego wewnętrznie przez funkcje Perla potrzebny jest moduł
59 Date::Calc lub Date::Manip.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 %build
65 %{__perl} Makefile.PL \
66         INSTALLDIRS=vendor
67
68 %{__make}
69
70 %{?with_tests:%{__make} test}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README
84 %{perl_vendorlib}/HTML/CalendarMonth.pm
85 %dir %{perl_vendorlib}/HTML/CalendarMonth
86 %{perl_vendorlib}/HTML/CalendarMonth/*.pm
87 %{perl_vendorlib}/HTML/CalendarMonth/DateTool/*.pm
88 %{_mandir}/man3/*
This page took 0.087361 seconds and 3 git commands to generate.