]> git.pld-linux.org Git - packages/perl-HTML-Calendar-Simple.git/blob - perl-HTML-Calendar-Simple.spec
use generic url
[packages/perl-HTML-Calendar-Simple.git] / perl-HTML-Calendar-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    HTML
6 %define         pnam    Calendar-Simple
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        HTML::Calendar::Simple - a simple HTML calendar
9 Summary(pl.UTF-8):      HTML::Calendar::Simple - prosty kalendarz w HTML
10 Name:           perl-HTML-Calendar-Simple
11 Version:        0.04
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4524a1c386f63e7fe6e9815ef37a13c5
18 URL:            http://search.cpan.org/dist/HTML-Calendar-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-CGI >= 2.752
23 BuildRequires:  perl-Date-Simple >= 1.03
24 BuildRequires:  perl-Test-Simple >= 0.40
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a simple module which will make an HTML representation of a
31 given month. You can add links to individual days, or in fact, any
32 sort of information you want.
33
34 Yes, the inspiration for this came out of me looking at
35 HTML::CalendarMonthSimple, and thinking 'Hmmm. A bit too complicated
36 for what I want. I know, I will write a simplified version.' So it was
37 done.
38
39 %description -l pl.UTF-8
40 Ten prosty moduł tworzy reprezentację podanego miesiąca w HTML. Można
41 dodawać odnośniki do poszczególnych dni, lub, w praktyce, dowolny
42 rodzaj informacji.
43
44 Inspiracja wzięła się z patrzenia na HTML::CalendarMonthSimple i
45 myślenia "Hmmm. Trochę zbyt skomplikowane do tego, co chcę. Wiem,
46 napiszę uproszczoną wersję.". No i została napisana.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %dir %{perl_vendorlib}/HTML/Calendar
72 %{perl_vendorlib}/HTML/Calendar/Simple.pm
73 %{_mandir}/man3/*
This page took 0.067052 seconds and 3 git commands to generate.