]> git.pld-linux.org Git - packages/perl-Guard.git/blob - perl-Guard.spec
3bd3b8da36bdb44cfad82f6d48ca2222e77f89d6
[packages/perl-Guard.git] / perl-Guard.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Guard
6 Summary:        Guard - safe cleanup blocks
7 Summary(pl.UTF-8):      Guard - bezpieczne czyszczenie bloków
8 Name:           perl-Guard
9 Version:        1.023
10 Release:        7
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  dbbb944601a31f60ee58954ad4cb65b4
16 URL:            http://search.cpan.org/dist/Guard/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module implements so-called "guards". A guard is something
23 (usually an object) that "guards" a resource, ensuring that it is
24 cleaned up when expected.
25
26 Specifically, this module supports two different types of guards:
27 guard objects, which execute a given code block when destroyed, and
28 scoped guards, which are tied to the scope exit.
29
30 %description -l pl.UTF-8
31 Moduł ten implementuje tzw. "strażników". Strażnik jest czymś (zwykle
32 obiektem), co strzeże zasobu, zapewniając jego usunięcie wtedy, kiedy
33 jest ono oczekiwane.
34
35 W szczegóności moduł ten obsługuje dwa rodzaje strażników:
36 - obiekty strażników, wykonujące dany blok kodu w trakcie niszczenia
37 - strażników zakresowych, powiązanych z zakończeniem zakresu (scope).
38
39 %prep
40 %setup -q -n %{pdir}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc COPYING Changes
63 %{perl_vendorarch}/Guard.pm
64 %dir %{perl_vendorarch}/auto/Guard
65 %attr(755,root,root) %{perl_vendorarch}/auto/Guard/Guard.so
66 %{_mandir}/man3/Guard.3pm*
This page took 0.179624 seconds and 2 git commands to generate.