]> git.pld-linux.org Git - packages/perl-Gtk2-Ex-FormFactory.git/blob - perl-Gtk2-Ex-FormFactory.spec
728fe2950d0ed7e275b77f12440225034eef5f83
[packages/perl-Gtk2-Ex-FormFactory.git] / perl-Gtk2-Ex-FormFactory.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Gtk2
8 %define         pnam    Ex-FormFactory
9 Summary:        Gtk2::Ex::FormFactory - makes building complex GUI's easy
10 Summary(pl.UTF-8):      Gtk2::Ex::FormFactory - moduł ułatwiający tworzenie złożonych GUI
11 Name:           perl-Gtk2-Ex-FormFactory
12 Version:        0.67
13 Release:        0.1
14 License:        LGPL v2.1+
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  17f0cfd4957196f9928d023a4801ed5c
18 URL:            http://search.cpan.org/dist/Gtk2-Ex-FormFactory/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-Gtk2
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a framework which tries to make building complex GUI's easy,
29 by offering these two main features:
30 - Consistent looking GUI without the need to code resp. tune each
31   widget by hand. Instead you declare the structure of your GUI,
32   connect it to the data of your program (which should be a well
33   defined set of objects) and control how this structure is
34   transformed into a specific layout in a very generic way.
35 - Automatically keep widget and object states in sync (in both
36   directions), even with complex data structures with a lot of
37   internal dependencies, object nesting etc.
38
39 %description -l pl.UTF-8
40 To jest szkielet próbujący ułatwić tworzenie złożonych GUI oferując
41 dwie główne cechy:
42 - spójnie wyglądające GUI bez potrzeby kodowania i dopasowywania
43   ręcznie każdego widgetu; zamiast tego wystarczy zadeklarować
44   strukturę GUI, połączyć ją z danymi programu (które powinny być
45   dobrze zdefiniowanym zbiorem obiektów) i kontrolować jak ta
46   struktura jest przekształcana na określony wygląd w bardzo
47   ogólny sposób.
48 - automatyczne utrzymywanie stanu widgetów i obiektów w synchronizacji
49   (w obu kierunkach), nawet dla złożonych struktur danych z dużą
50   liczbą wewnętrznych zależności, zagnieżdżonymi obiektami itp.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %{__install} -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67
68 %{__make} pure_install \
69         DESTDIR=$RPM_BUILD_ROOT
70 install tutorial/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 mv $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/README{,.tutorial}
72 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %{perl_vendorlib}/Gtk2/Ex/FormFactory.pm
81 %dir %{perl_vendorlib}/Gtk2/Ex/FormFactory
82 %{perl_vendorlib}/Gtk2/Ex/FormFactory/*pm
83 %dir %{_examplesdir}/%{name}-%{version}
84 %{_examplesdir}/%{name}-%{version}/*
85 %{_mandir}/man3/*
This page took 0.085901 seconds and 2 git commands to generate.