]> git.pld-linux.org Git - packages/perl-Gtk2-Ex-FormFactory.git/blob - perl-Gtk2-Ex-FormFactory.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Gtk2-Ex-FormFactory.git] / perl-Gtk2-Ex-FormFactory.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    Gtk2
7 %define         pnam    Ex-FormFactory
8 Summary:        Gtk2::Ex::FormFactory - makes building complex GUI's easy
9 Summary(pl.UTF-8):      Gtk2::Ex::FormFactory - moduł ułatwiający tworzenie złożonych GUI
10 Name:           perl-Gtk2-Ex-FormFactory
11 Version:        0.67
12 Release:        0.1
13 License:        LGPL v2.1+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  17f0cfd4957196f9928d023a4801ed5c
17 URL:            http://search.cpan.org/dist/Gtk2-Ex-FormFactory/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with autodeps} || %{with tests}
21 BuildRequires:  perl-Gtk2
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a framework which tries to make building complex GUI's easy,
28 by offering these two main features:
29 - Consistent looking GUI without the need to code resp. tune each
30   widget by hand. Instead you declare the structure of your GUI,
31   connect it to the data of your program (which should be a well
32   defined set of objects) and control how this structure is
33   transformed into a specific layout in a very generic way.
34 - Automatically keep widget and object states in sync (in both
35   directions), even with complex data structures with a lot of
36   internal dependencies, object nesting etc.
37
38 %description -l pl.UTF-8
39 To jest szkielet próbujący ułatwić tworzenie złożonych GUI oferując
40 dwie główne cechy:
41 - spójnie wyglądające GUI bez potrzeby kodowania i dopasowywania
42   ręcznie każdego widgetu; zamiast tego wystarczy zadeklarować
43   strukturę GUI, połączyć ją z danymi programu (które powinny być
44   dobrze zdefiniowanym zbiorem obiektów) i kontrolować jak ta
45   struktura jest przekształcana na określony wygląd w bardzo
46   ogólny sposób.
47 - automatyczne utrzymywanie stanu widgetów i obiektów w synchronizacji
48   (w obu kierunkach), nawet dla złożonych struktur danych z dużą
49   liczbą wewnętrznych zależności, zagnieżdżonymi obiektami itp.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__install} -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69 install tutorial/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70 mv $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/README{,.tutorial}
71 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %{perl_vendorlib}/Gtk2/Ex/FormFactory.pm
80 %dir %{perl_vendorlib}/Gtk2/Ex/FormFactory
81 %{perl_vendorlib}/Gtk2/Ex/FormFactory/*pm
82 %dir %{_examplesdir}/%{name}-%{version}
83 %{_examplesdir}/%{name}-%{version}/*
84 %{_mandir}/man3/*
This page took 0.066515 seconds and 3 git commands to generate.