]> git.pld-linux.org Git - packages/perl-GraphViz-ISA.git/blob - perl-GraphViz-ISA.spec
use generic url
[packages/perl-GraphViz-ISA.git] / perl-GraphViz-ISA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    GraphViz
6 %define         pnam    ISA
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        GraphViz::ISA Perl module - graphing @ISA hierarchies at run-time
9 Summary(pl.UTF-8):      Moduł Perla GraphViz::ISA - wizualizacja hierarchii @ISA w czasie działania
10 Name:           perl-GraphViz-ISA
11 Version:        0.01
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  93b279c6fd57abd614ff71d34f8ed839
18 URL:            http://search.cpan.org/dist/GraphViz-ISA/
19 BuildRequires:  perl-GraphViz >= 0.11
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       perl-GraphViz >= 0.11
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This class constructs a graph showing the `@ISA' hierarchy (note: not
28 object hierarchies) from a package name or a blessed scalar.
29
30 %description -l pl.UTF-8
31 Ta klasa konstruuje graf obrazujący hierarchię @ISA (ale nie
32 hierarchie obiektów) z nazwy pakietu lub "pobłogosławionej" wielkości.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/GraphViz/ISA.pm
57 %{_mandir}/man3/*
This page took 0.05937 seconds and 3 git commands to generate.