]> git.pld-linux.org Git - packages/perl-Google-ProtocolBuffers.git/blob - perl-Google-ProtocolBuffers.spec
adapter url
[packages/perl-Google-ProtocolBuffers.git] / perl-Google-ProtocolBuffers.spec
1 # Conditional build:
2 %bcond_without  tests           # do not perform "make test"
3
4 %define         pdir    Google
5 %define         pnam    ProtocolBuffers
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Google::ProtocolBuffers - simple interface to Google Protocol Buffers
8 Name:           perl-%{pdir}-%{pnam}
9 Version:        0.11
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  f328b874b291018225201713054b3465
15 URL:            http://search.cpan.org/dist/Google-ProtocolBuffers/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-Class-Accessor
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Google Protocol Buffers is a data serialization format. It is binary
26 (and hence compact and fast for serialization) and as extendable as
27 XML; its nearest analogues are Thrift and ASN.1. There are official
28 mappings for C++, Java and Python languages; this library is a mapping
29 for Perl.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 find $RPM_BUILD_ROOT -name .DS_Store | xargs -r rm -f
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %attr(755,root,root) %{_bindir}/*
58 %dir %{perl_vendorlib}/%{pdir}
59 %dir %{perl_vendorlib}/%{pdir}/%{pnam}
60 %{perl_vendorlib}/%{pdir}/*.pm
61 %{perl_vendorlib}/%{pdir}/%{pnam}/*.pm
62 %{_mandir}/man3/*
This page took 0.074951 seconds and 3 git commands to generate.