]> git.pld-linux.org Git - packages/perl-Goo-Canvas.git/blob - perl-Goo-Canvas.spec
- release 9 (by relup.sh)
[packages/perl-Goo-Canvas.git] / perl-Goo-Canvas.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Goo
6 %define         pnam    Canvas
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Goo::Canvas - Perl interface to the GooCanvas
9 Name:           perl-Goo-Canvas
10 Version:        0.06
11 Release:        9
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/Y/YE/YEWENBIN/Goo-Canvas-%{version}.tar.gz
16 # Source0-md5:  7dfe0be8c17bfd641d18384d4fd8fb23
17 URL:            http://search.cpan.org/dist/Goo-Canvas/
18 BuildRequires:  goocanvas-devel >= 0.9
19 BuildRequires:  perl(ExtUtils::Depends) >= 0.2
20 BuildRequires:  perl(ExtUtils::PkgConfig) >= 1.0
21 BuildRequires:  perl-Cairo >= 1.00
22 BuildRequires:  perl-Glib >= 1.103
23 BuildRequires:  perl-Gtk2-devel >= 1.100
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 GTK+ does't has an buildin canvas widget. GooCanvas is wonderful. It
30 is easy to use and has powerful and extensible way to create items in
31 canvas. Just try it.
32
33 For more documents, please read GooCanvas Manual and the demo programs
34 provided in the source distribution in both perl-Goo::Canvas and
35 GooCanvas.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorarch}/Goo
62 %{perl_vendorarch}/Goo/*.pm
63 %dir %{perl_vendorarch}/auto/Goo
64 %dir %{perl_vendorarch}/auto/Goo/Canvas
65 %attr(755,root,root) %{perl_vendorarch}/auto/Goo/Canvas/*.so
66 %{_mandir}/man3/*
This page took 0.066674 seconds and 3 git commands to generate.