]> git.pld-linux.org Git - packages/perl-Gnome2-VFS.git/blob - perl-Gnome2-VFS.spec
- updated to 1.082
[packages/perl-Gnome2-VFS.git] / perl-Gnome2-VFS.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Gnome2
7 %define         pnam    VFS
8 Summary:        Perl bindings for the GNOME Virtual File System
9 Summary(pl.UTF-8):      Dowiązania Perla dla biblioteki GNOME Virtual File System
10 Name:           perl-Gnome2-VFS
11 Version:        1.082
12 Release:        1
13 License:        LGPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://downloads.sourceforge.net/gtk2-perl/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  374e7d611d080d893bb3da9d40c64733
17 URL:            http://gtk2-perl.sourceforge.net/
18 BuildRequires:  gnome-vfs2-devel >= 2.14.1
19 BuildRequires:  perl-ExtUtils-Depends >= 0.201
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
21 BuildRequires:  perl-Glib >= 1.120
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       gnome-vfs2-libs >= 2.14.1
25 Requires:       perl-Glib >= 1.120
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The VFS module allows a perl developer to use the GNOME Virtual File
30 System.
31
32 %description -l pl.UTF-8
33 Moduł VFS pozwala programistom perlowym na używanie biblioteki GNOME
34 Virtual File System.
35
36 %package devel
37 Summary:        Development files for Perl Gnome2-VFS bindings
38 Summary(pl.UTF-8):      Pliki programistyczne wiązań Gnome2-VFS dla Perla
39 Group:          Development/Languages/Perl
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       gnome-vfs2-devel >= 2.14.1
42 Requires:       perl-Cairo-devel
43 Requires:       perl-Glib >= 1.120
44
45 %description devel
46 Development files for Perl Gnome2-VFS bindings.
47
48 %description devel -l pl.UTF-8
49 Pliki programistyczne wiązań Gnome2-VFS dla Perla.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57
58 %{__make} \
59         CC="%{__cc}" \
60         OPTIMIZE="%{rpmcflags}"
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/VFS/{*,*/*,*/*/*}.pod
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc NEWS README
78 %{perl_vendorarch}/Gnome2/VFS.pm
79 %dir %{perl_vendorarch}/Gnome2/VFS
80 %dir %{perl_vendorarch}/auto/Gnome2/VFS
81 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/VFS/VFS.so
82 %{_mandir}/man3/Gnome2::VFS*.3pm*
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{perl_vendorarch}/Gnome2/VFS/Install
This page took 0.066058 seconds and 4 git commands to generate.