]> git.pld-linux.org Git - packages/perl-Gnome2-VFS.git/blob - perl-Gnome2-VFS.spec
- release 8 (by relup.sh)
[packages/perl-Gnome2-VFS.git] / perl-Gnome2-VFS.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Gnome2
7 %define         pnam    VFS
8 Summary:        Perl bindings for the GNOME Virtual File System
9 Summary(pl.UTF-8):      Dowiązania Perla dla biblioteki GNOME Virtual File System
10 Name:           perl-Gnome2-VFS
11 Version:        1.081
12 Release:        8
13 License:        LGPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Gnome2/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3d220cbbe9f1ebc78d7047593f9cd633
17 URL:            http://gtk2-perl.sourceforge.net/
18 BuildRequires:  gnome-vfs2-devel >= 2.14.1
19 BuildRequires:  perl-ExtUtils-Depends >= 0.201
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
21 BuildRequires:  perl-Glib >= 1.120
22 BuildRequires:  perl-Gtk2 >= 1.121
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       gnome-vfs2-libs >= 2.14.1
26 Requires:       perl-Glib >= 1.120
27 Requires:       perl-Gtk2 >= 1.121
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The VFS module allows a perl developer to use the GNOME Virtual File
32 System.
33
34 %description -l pl.UTF-8
35 Moduł VFS pozwala programistom perlowym na używanie biblioteki GNOME
36 Virtual File System.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/VFS/{*,*/*,*/*/*}.pod
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog NEWS README
65 %dir %{perl_vendorarch}/Gnome2/VFS
66 %{perl_vendorarch}/Gnome2/VFS/Install
67 %{perl_vendorarch}/Gnome2/*.pm
68 %dir %{perl_vendorarch}/auto/Gnome2/VFS
69 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/VFS/*.so
70 %{_mandir}/man3/Gnome2::VFS*.3pm*
This page took 0.0476 seconds and 3 git commands to generate.