]> git.pld-linux.org Git - packages/perl-Gnome2-PanelApplet.git/blob - perl-Gnome2-PanelApplet.spec
f669de42cf14bec881ad1d35562abefd011035f9
[packages/perl-Gnome2-PanelApplet.git] / perl-Gnome2-PanelApplet.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires X server)
4 #
5 %define         pnam    Gnome2-PanelApplet
6 Summary:        Perl interface to the GNOME's applet library
7 Summary(pl.UTF-8):      Interfejs perlowy do biblioteki apletów GNOME
8 Name:           perl-Gnome2-PanelApplet
9 Version:        0.03
10 Release:        2
11 License:        LGPL v2.1+
12 Group:          Development/Languages/Perl
13 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
14 # Source0-md5:  f41e33ef3cbba5c3be1a17038ccc877e
15 URL:            http://gtk2-perl.sourceforge.net/
16 BuildRequires:  gnome-panel-devel >= 2.0.0
17 # probably should be required by perl-Gnome2
18 BuildRequires:  libgnomeui-devel
19 BuildRequires:  perl-ExtUtils-Depends >= 0.200
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
21 BuildRequires:  perl-Glib >= 1.160
22 BuildRequires:  perl-Gnome2 >= 1.042
23 BuildRequires:  perl-Gnome2-GConf >= 1.044
24 BuildRequires:  perl-Gtk2 >= 1.160
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuils(macros) >= 1.745
29 Requires:       gnome-panel-libs >= 2.0.0
30 Requires:       perl-Glib >= 1.160
31 Requires:       perl-Gnome2 >= 1.042
32 Requires:       perl-Gnome2-GConf >= 1.044
33 Requires:       perl-Gtk2 >= 1.160
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Perl interface to the GNOME's applet library.
38
39 %description -l pl.UTF-8
40 Interfejs perlowy do biblioteki apletów GNOME.
41
42 %prep
43 %setup -q -n %{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/PanelApplet/*.pod
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc AUTHOR NEWS README
69 %{perl_vendorarch}/Gnome2/PanelApplet.pm
70 %dir %{perl_vendorarch}/Gnome2/PanelApplet
71 %{perl_vendorarch}/Gnome2/PanelApplet/Install
72 %dir %{perl_vendorarch}/auto/Gnome2/PanelApplet
73 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/PanelApplet/PanelApplet.so
74 %{_mandir}/man3/Gnome2::PanelApplet*.3pm*
This page took 0.075976 seconds and 2 git commands to generate.