]> git.pld-linux.org Git - packages/perl-Gearman-Server.git/blob - perl-Gearman-Server.spec
use generic url
[packages/perl-Gearman-Server.git] / perl-Gearman-Server.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Gearman
6 %define pnam    Server
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Gearman::Server - function call "router" and load balancer
9 Name:           perl-Gearman-Server
10 Version:        1.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/Gearman-Server-%{version}.tar.gz
16 # Source0-md5:  3d107089f7266ab91d66d9a7bd90430f
17 URL:            http://search.cpan.org/dist/Gearman-Server/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 You run a Gearman server (or more likely, many of them for both
25 high-availability and load balancing), then have workers (using
26 Gearman::Worker from the Gearman module, or libraries for other
27 languages) register their ability to do certain functions to all of
28 them, and then clients (using Gearman::Client, Gearman::Client::Async,
29 etc) request work to be done from one of the Gearman servers.
30
31 The servers connect them, routing function call requests to the
32 appropriate workers, multiplexing responses to duplicate requests as
33 requested, etc.
34
35 More than likely, you want to use the provided gearmand wrapper
36 script, and not use Gearman::Server directly.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc CHANGES
59 %{perl_vendorlib}/Gearman/*.pm
60 %{perl_vendorlib}/Gearman/Server
61 %{_mandir}/man3/*
62 %attr(755,root,root) %{_bindir}/gearmand
63 %{_mandir}/man1/*
This page took 0.066363 seconds and 3 git commands to generate.