]> git.pld-linux.org Git - packages/perl-Gearman-Client-Async.git/blob - perl-Gearman-Client-Async.spec
use generic url
[packages/perl-Gearman-Client-Async.git] / perl-Gearman-Client-Async.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define pdir    Gearman
7 %define pnam    Client-Async
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Gearman::Client::Async - Asynchronous client module for Gearman for Danga::Socket applications
10 Name:           perl-Gearman-Client-Async
11 Version:        0.94
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/Gearman-Client-Async-%{version}.tar.gz
17 # Source0-md5:  71dcadfb434202dbdf4798f2ec93b32f
18 URL:            http://search.cpan.org/dist/Gearman-Client-Async/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-Danga-Socket >= 1.52
23 BuildRequires:  perl-Gearman >= 1.05
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Asynchronous client module for Gearman for Danga::Socket applications.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc CHANGES README.txt TODO
53 %{perl_vendorlib}/Gearman/Client/*.pm
54 %{perl_vendorlib}/Gearman/Client/Async
55 %{_mandir}/man3/*
This page took 0.194913 seconds and 3 git commands to generate.