]> git.pld-linux.org Git - packages/perl-Games-Chess.git/blob - perl-Games-Chess.spec
use generic url
[packages/perl-Games-Chess.git] / perl-Games-Chess.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Games
6 %define         pnam    Chess
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Games::Chess - represent chess positions and games
9 Summary(pl.UTF-8):      Games::Chess - reprezentacja ruchów i pozycji szachowych
10 Name:           perl-Games-Chess
11 Version:        0.003
12 Release:        12
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  42f05fe388999fd712e3011b9f39bd70
18 URL:            http://search.cpan.org/dist/Games-Chess/
19 BuildRequires:  perl-GD
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Games::Chess Perl module provides Games::Chess::Piece and
27 Games::Chess::Position classes to represent a chess game data.
28
29 %description -l pl.UTF-8
30 Moduł Perla Games::Chess udostępnia klasy Games::Chess::Piece i
31 Games::Chess::Position służące do przedstawiania danych w grze
32 szachowej.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README
56 %{perl_vendorlib}/Games/Chess.pm
57 %{_mandir}/man3/*
This page took 0.076508 seconds and 3 git commands to generate.