]> git.pld-linux.org Git - packages/perl-GD.git/blob - perl-GD.spec
rebuild with perl 5.32
[packages/perl-GD.git] / perl-GD.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 Summary:        GD - interface to GD graphics library
6 Summary(pl.UTF-8):      GD - interfejs do biblioteki graficznej GD
7 Name:           perl-GD
8 Version:        2.71
9 Release:        3
10 License:        Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/GD/GD-%{version}.tar.gz
13 # Source0-md5:  1e2534e1d0db57d6aad438f15ca63253
14 Patch0:         %{name}-paths.patch
15 URL:            http://search.cpan.org/dist/GD/
16 BuildRequires:  gd-devel >= 2.0.28
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  perl-ExtUtils-PkgConfig
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Requires:       gd >= 2.0.28
21 Provides:       perl-GD(gif) = %{version}-%{release}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 GD.pm is a Perl interface to Thomas Boutell's GD graphics library. GD
26 allows you to create color drawings using a large number of graphics
27 primitives, and emit the drawings as PNG files.
28
29 %description -l pl.UTF-8
30 GD.pm jest perlowym interfejsem do biblioteki graficznej GD Thomasa
31 Boutella. GD pozwala na tworzenie kolorowych rysunków przy użyciu
32 dużej liczby graficznych prymitywów oraz zapisywanie ich w formacie
33 PNG.
34
35 %prep
36 %setup -q -n GD-%{version}
37 %patch0 -p1
38
39
40 %build
41 %{__perl} Makefile.PL </dev/null \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{perl_vendorlib}/GD}
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 cp -fa demos bdf_scripts \
57         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 gzip -9nf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/bdf_scripts/README
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc ChangeLog README*
67 %attr(755,root,root) %{_bindir}/bdf2gdfont.pl
68 %{perl_vendorarch}/GD.pm
69 %{perl_vendorarch}/GD
70 %dir %{perl_vendorarch}/auto/GD
71 %{perl_vendorarch}/auto/GD/autosplit.ix
72 %attr(755,root,root) %{perl_vendorarch}/auto/GD/GD.so
73 %dir %{perl_vendorlib}/GD
74 %{_mandir}/man1/bdf2gdfont.pl.1*
75 %{_mandir}/man3/GD*.3pm*
76 %{_examplesdir}/%{name}-%{version}
This page took 0.060111 seconds and 3 git commands to generate.