]> git.pld-linux.org Git - packages/perl-Fuse.git/blob - perl-Fuse.spec
- fix Source0 URL
[packages/perl-Fuse.git] / perl-Fuse.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do perform "make test"; disabled fusermount restricted
4
5 %define         pdir    Fuse
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Fuse - write filesystems in Perl using FUSE
8 Name:           perl-Fuse
9 Version:        0.16.1
10 Release:        1
11 # same as perl (REMOVE THIS LINE IF NOT TRUE)
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/DPATES/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  29534329808d8cf42fc78ca26c6fa698
16 URL:            http://search.cpan.org/dist/Fuse/
17 BuildRequires:  libfuse-devel
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This lets you implement filesystems in perl, through the FUSE
24 (Filesystem in USErspace) kernel/lib interface.
25
26 FUSE expects you to implement callbacks for the various functions.
27
28 In the following definitions, "errno" can be 0 (for a success),
29 - -EINVAL, -ENOENT, -EONFIRE, any integer less than 1 really.
30
31 You can import standard error constants by saying something like "use
32 POSIX qw(EDOTDOT ENOANO);".
33
34 Every constant you need (file types, open() flags, error values, etc)
35 can be imported either from POSIX or from Fcntl, often both. See their
36 respective documentations, for more information.
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS Changes README
65 %{perl_vendorarch}/Fuse.pm
66 %dir %{perl_vendorarch}/auto/Fuse/
67 %attr(755,root,root) %{perl_vendorarch}/auto/Fuse/*.so
68 %{perl_vendorarch}/auto/Fuse/autosplit.ix
69 %{_mandir}/man3/*
70 %{_examplesdir}/%{name}-%{version}
This page took 0.03085 seconds and 3 git commands to generate.