]> git.pld-linux.org Git - packages/perl-Font-FreeType.git/blob - perl-Font-FreeType.spec
rebuild with perl 5.32
[packages/perl-Font-FreeType.git] / perl-Font-FreeType.spec
1 #
2 # TODO: check why tests fail (freetype expert needed)
3 #
4 # Conditional build:
5 %bcond_with     tests   # do perform "make test" (fails with recent freetype versions)
6 #
7 %define         pdir    Font
8 %define         pnam    FreeType
9 Summary:        Font::FreeType - read font files and render glyphs from Perl using FreeType2
10 Summary(pl.UTF-8):      Font::FreeType - odczyt plików fontów oraz rendering znaków graficznych za pomocą FreeType2
11 Name:           perl-Font-FreeType
12 Version:        0.03
13 Release:        17
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Font/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  47b9483c92f1b2df0bbb5258a6a596b2
19 Patch0:         %{name}-gcc4.patch
20 URL:            http://search.cpan.org/dist/Font-FreeType/
21 BuildRequires:  freetype-devel >= 2
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module allows Perl programs to conveniently read information from
28 font files. All the font access is done through the FreeType2 library,
29 which supports many formats. It can render images of characters with
30 high-quality hinting and antialiasing, extract metrics information,
31 and extract the outlines of characters in scalable formats like
32 TrueType.
33
34 %description -l pl.UTF-8
35 Moduł ten umożliwia programom perlowym odczyt informacji z plików
36 fontów w wygodny sposób. Cały dostęp do fontów odbywa sie poprzez
37 bibliotekę FreeType2, która wspiera wiele formatów. Umożliwia
38 renderowanie obrazów znaków, wysokiej jakości hinting i antyaliasing,
39 pobieranie informacji o metryce oraz pobieranie zarysów znaków dla
40 formatów skalowalnych, takich jak TrueType.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %patch0 -p1
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %dir %{perl_vendorarch}/Font
67 %{perl_vendorarch}/Font/FreeType.pm
68 %{perl_vendorarch}/Font/FreeType
69 %dir %{perl_vendorarch}/auto/Font
70 %dir %{perl_vendorarch}/auto/Font/FreeType
71 %attr(755,root,root) %{perl_vendorarch}/auto/Font/FreeType/FreeType.so
72 %{_mandir}/man3/Font::FreeType*.3pm*
This page took 0.143464 seconds and 3 git commands to generate.