]> git.pld-linux.org Git - packages/perl-Filesys-Virtual-Async.git/blob - perl-Filesys-Virtual-Async.spec
use generic url
[packages/perl-Filesys-Virtual-Async.git] / perl-Filesys-Virtual-Async.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Filesys
6 %define pnam    Virtual-Async
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Filesys::Virtual::Async - Base class for non blocking virtual filesystems
9 Name:           perl-Filesys-Virtual-Async
10 Version:        0.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  635bf2e6679b231c48684ef020f98880
17 URL:            http://search.cpan.org/dist/Filesys-Virtual-Async/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The goal of Filesys::Virtual::Async is to provide an interface like
25 IO::AIO for a non blocking virtual filesystem
26
27 This is a base class, see the SEE ALSO section below
28
29 This module is still in flux to an extent. If you'd like to suggest
30 changes, please drop in the irc channel #poe on irc.perl.org and speak
31 with xantus[] or Apocalypse
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/Filesys/Virtual/*.pm
56 #%%{perl_vendorlib}/Filesys/Virtual/Async
57 %{_mandir}/man3/*
This page took 0.254845 seconds and 3 git commands to generate.