]> git.pld-linux.org Git - packages/perl-Filesys-Virtual-Async-Dispatcher.git/blob - perl-Filesys-Virtual-Async-Dispatcher.spec
9ff1366d18220be90a2978f1dc073f6d12ca88bb
[packages/perl-Filesys-Virtual-Async-Dispatcher.git] / perl-Filesys-Virtual-Async-Dispatcher.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Filesys
7 %define pnam    Virtual-Async-Dispatcher
8 Summary:        perl(Filesys::Virtual::Async::Dispatcher)
9 #Summary(pl.UTF-8):     
10 Name:           perl-Filesys-Virtual-Async-Dispatcher
11 Version:        0.01
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  de5133e55de1250f1e4a0d1d1bb47112
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/Filesys-Virtual-Async-Dispatcher/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl(Filesys::Virtual::Async)
24 BuildRequires:  perl-Test-Simple >= 0.86
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module allows you to have arbitrary combinations of Filesys::Virtual::Async objects mounted and expose a
31 single filesystem. The dispatcher will correctly map methods to the proper object based on their path in the
32 filesystem. This works similar to the way linux manages mounts in a single "visible" filesystem.
33
34 It might be a bit confusing on how the paths work at first. I'm sure with a bit of experimentation and looking
35 at the documentation for the Filesys::Virtual::Async::XYZ subclass, you'll get it!
36
37 This module makes extensive use of the functions in File::Spec to be portable, so it might trip you up if
38 you are developing on a linux box and trying to mount '/foo' on a win32 box :)
39
40
41
42 # %description -l pl.UTF-8
43 # TODO
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Filesys/Virtual/Async/*.pm
71 #%%{perl_vendorlib}/Filesys/Virtual/Async/Dispatcher
72 %{_mandir}/man3/*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.051792 seconds and 2 git commands to generate.