]> git.pld-linux.org Git - packages/perl-Filesys-Virtual-Async-Dispatcher.git/blob - perl-Filesys-Virtual-Async-Dispatcher.spec
use generic url
[packages/perl-Filesys-Virtual-Async-Dispatcher.git] / perl-Filesys-Virtual-Async-Dispatcher.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Filesys
6 %define pnam    Virtual-Async-Dispatcher
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        perl(Filesys::Virtual::Async::Dispatcher)
9 Name:           perl-Filesys-Virtual-Async-Dispatcher
10 Version:        0.01
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  de5133e55de1250f1e4a0d1d1bb47112
17 URL:            http://search.cpan.org/dist/Filesys-Virtual-Async-Dispatcher/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Filesys::Virtual::Async)
22 BuildRequires:  perl-Test-Simple >= 0.86
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module allows you to have arbitrary combinations of
29 Filesys::Virtual::Async objects mounted and expose a single
30 filesystem. The dispatcher will correctly map methods to the proper
31 object based on their path in the filesystem. This works similar to
32 the way linux manages mounts in a single "visible" filesystem.
33
34 It might be a bit confusing on how the paths work at first. I'm sure
35 with a bit of experimentation and looking at the documentation for the
36 Filesys::Virtual::Async::XYZ subclass, you'll get it!
37
38 This module makes extensive use of the functions in File::Spec to be
39 portable, so it might trip you up if you are developing on a linux box
40 and trying to mount '/foo' on a win32 box :)
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Build.PL \
47         destdir=$RPM_BUILD_ROOT \
48         installdirs=vendor
49 ./Build
50
51 %{?with_tests:./Build test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 ./Build install
57
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/Filesys/Virtual/Async/*.pm
68 #%%{perl_vendorlib}/Filesys/Virtual/Async/Dispatcher
69 %{_mandir}/man3/*
70 %{_examplesdir}/%{name}-%{version}
This page took 0.067791 seconds and 3 git commands to generate.