]> git.pld-linux.org Git - packages/perl-Filesys-SmbClient.git/blob - perl-Filesys-SmbClient.spec
rebuild with perl 5.32
[packages/perl-Filesys-SmbClient.git] / perl-Filesys-SmbClient.spec
1 # TODO:
2 # - make cgi scripts from doc as separate packages
3 #
4 # Conditional build:
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %define         pdir    Filesys
8 %define         pnam    SmbClient
9 Summary:        Filesys::SmbClient - interface for access Samba filesystem
10 Summary(pl.UTF-8):      Filesys::SmbClient - interfejs dostępu do systemu plików Samby
11 Name:           perl-Filesys-SmbClient
12 Version:        3.2
13 Release:        9
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8a4205fe748aac7f43fb2a0e8ef502b2
18 URL:            http://search.cpan.org/dist/Filesys-SmbClient/
19 Patch0:         Makefile.patch
20 Patch1:         samba4.patch
21 BuildRequires:  autoconf
22 BuildRequires:  libsmbclient-devel
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define _noautocompressdoc *.cgi
28
29 %description
30 Filesys::SmbClient Perl module provides interface to access routine
31 defined in libsmbclient.so and, using this routine, Samba filesystem.
32
33 %description -l pl.UTF-8
34 Moduł Perla Filesys::SmbClient stanowi interfejs dostępu do procedury
35 zdefiniowanej w libsmbclient.so i, za pośrednictwem tej procedury, do
36 systemu plików Samby.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 %{__autoconf}
45 %configure
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make} \
50         CC="%{__cc}" \
51         CFLAGS="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes smb2www-2.cgi smb2www.css
67 %dir %{perl_vendorarch}/Filesys
68 %{perl_vendorarch}/Filesys/*.pm
69 %dir %{perl_vendorarch}/auto/Filesys
70 %dir %{perl_vendorarch}/auto/Filesys/SmbClient
71 # empty autosplit.ix
72 #%%{perl_vendorarch}/auto/Filesys/SmbClient/autosplit.ix
73 %attr(755,root,root) %{perl_vendorarch}/auto/Filesys/SmbClient/SmbClient.so
74 # this is NOT duplicate:
75 #%dir %{perl_vendorarch}/auto/Filesys/Smbclient
76 #%dir %{perl_vendorarch}/auto/Filesys/Smbclient/libauthSamba
77 #%%{perl_vendorarch}/auto/Filesys/Smbclient/libauthSamba/libauthSamba.a
78 %{_mandir}/man3/*
This page took 0.033976 seconds and 3 git commands to generate.