]> git.pld-linux.org Git - packages/perl-Filesys-SmbClient.git/blob - perl-Filesys-SmbClient.spec
2c4d2e55db64697b7ec5b4b3e7dfed48ea12aac9
[packages/perl-Filesys-SmbClient.git] / perl-Filesys-SmbClient.spec
1 # TODO:
2 # - make cgi scripts from doc as separate packages
3 #
4 # Conditional build:
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    Filesys
9 %define         pnam    SmbClient
10 Summary:        Filesys::SmbClient - interface for access Samba filesystem
11 Summary(pl.UTF-8):      Filesys::SmbClient - interfejs dostępu do systemu plików Samby
12 Name:           perl-Filesys-SmbClient
13 Version:        3.2
14 Release:        2
15 License:        GPL or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  8a4205fe748aac7f43fb2a0e8ef502b2
19 URL:            http://search.cpan.org/dist/Filesys-SmbClient/
20 Patch0:         Makefile.patch
21 Patch1:         samba4.patch
22 BuildRequires:  autoconf
23 BuildRequires:  libsmbclient-devel
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define _noautocompressdoc *.cgi
29
30 %description
31 Filesys::SmbClient Perl module provides interface to access routine
32 defined in libsmbclient.so and, using this routine, Samba filesystem.
33
34 %description -l pl.UTF-8
35 Moduł Perla Filesys::SmbClient stanowi interfejs dostępu do procedury
36 zdefiniowanej w libsmbclient.so i, za pośrednictwem tej procedury, do
37 systemu plików Samby.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 %patch0 -p1
42 %patch1 -p1
43
44 %build
45 %{__autoconf}
46 %configure
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49
50 %{__make} \
51         CC="%{__cc}" \
52         CFLAGS="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes smb2www-2.cgi smb2www.css
68 %dir %{perl_vendorarch}/Filesys
69 %{perl_vendorarch}/Filesys/*.pm
70 %dir %{perl_vendorarch}/auto/Filesys
71 %dir %{perl_vendorarch}/auto/Filesys/SmbClient
72 # empty autosplit.ix
73 #%%{perl_vendorarch}/auto/Filesys/SmbClient/autosplit.ix
74 %attr(755,root,root) %{perl_vendorarch}/auto/Filesys/SmbClient/SmbClient.so
75 # this is NOT duplicate:
76 #%dir %{perl_vendorarch}/auto/Filesys/Smbclient
77 #%dir %{perl_vendorarch}/auto/Filesys/Smbclient/libauthSamba
78 #%%{perl_vendorarch}/auto/Filesys/Smbclient/libauthSamba/libauthSamba.a
79 %{_mandir}/man3/*
This page took 0.052578 seconds and 2 git commands to generate.