]> git.pld-linux.org Git - packages/perl-Filesys-Notify-Simple.git/blob - perl-Filesys-Notify-Simple.spec
use generic url
[packages/perl-Filesys-Notify-Simple.git] / perl-Filesys-Notify-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Filesys
6 %define         pnam    Notify-Simple
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Filesys::Notify::Simple - Simple and dumb file system watcher
9 Name:           perl-Filesys-Notify-Simple
10 Version:        0.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  82a1ae968a457c7dc37367ab43a97da8
17 URL:            http://search.cpan.org/dist/Filesys-Notify-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Filesys::Notify::Simple is a simple but unified interface to get
25 notifications of changes to a given filesystem path. It utilizes
26 inotify2 on Linux and fsevents on OS X if they're installed, with a
27 fallback to the full directory scan if they're not available.
28
29 There are some limitations in this module. If you don't like it, use
30 File::ChangeNotify.
31
32 In return, this module doesn't depend on any non-core modules.
33 Platform specific optimizations with Linux::Inotify2 and Mac::FSEvents
34 are truely optional.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %dir %{perl_vendorlib}/Filesys/Notify
59 %{perl_vendorlib}/Filesys/Notify/*.pm
60 %{_mandir}/man3/*
This page took 0.04937 seconds and 3 git commands to generate.