]> git.pld-linux.org Git - packages/perl-Filesys-DiskSpace.git/blob - perl-Filesys-DiskSpace.spec
use generic url
[packages/perl-Filesys-DiskSpace.git] / perl-Filesys-DiskSpace.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform crappy "make test"
4
5 %define         pdir    Filesys
6 %define         pnam    DiskSpace
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Filesys::DiskSpace - Perl df
9 Summary(pl.UTF-8):      Filesys::DiskSpace - df w Perlu
10 Name:           perl-Filesys-DiskSpace
11 Version:        0.05
12 Release:        9
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b95651483e0234db33561a53708e007d
18 URL:            http://search.cpan.org/dist/Filesys-DiskSpace/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Filesys::DiskSpace Perl module is used for displaying information
26 of a file system such as its type, the amount of disk space occupied,
27 the total disk space and the number of inodes.
28
29 %description -l pl.UTF-8
30 Moduł Perla Filesys::DiskSpace służy do wypisywania takich informacji
31 o systemie plików, jak jego typ, ilość zajętego miejsca na dysku,
32 łączna pojemność dysku i liczba i-węzłów.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README
56 %{perl_vendorlib}/Filesys/DiskSpace.pm
57 %{_mandir}/man3/*
This page took 0.112594 seconds and 3 git commands to generate.