]> git.pld-linux.org Git - packages/perl-Filesys-DiskFree.git/blob - perl-Filesys-DiskFree.spec
359bf78aa7cf29f8b5cb9cdc3b8c1e7d719165aa
[packages/perl-Filesys-DiskFree.git] / perl-Filesys-DiskFree.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Filesys
7 %define         pnam    DiskFree
8 Summary:        Filesys::DiskFree - perform the UNIX command 'df' in a portable fashion
9 Summary(pl.UTF-8):      Filesys::DiskFree - przenośna postać uniksowego polecenia 'df'
10 Name:           perl-Filesys-DiskFree
11 Version:        0.06
12 Release:        13
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e39b3b10468fd98973ce76a97351f3c4
18 Patch0:         %{name}-paths.patch
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-devel >= 1:5.8.0
21 Obsoletes:      perl-DiskFree
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Filesys::DiskFree Perl module does about what the UNIX command df(1)
27 does, listing the mounted disks, and the amount of free space used and
28 available.
29
30 %description -l pl.UTF-8
31 Moduł Perla Filesys::DiskFree robi to samo, co uniksowe polecenie
32 df(1), wypisuje listę zamontowanych dysków oraz ilość użytego i
33 dostępnego miejsca na nich.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37 %patch0 -p1
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 cp -af eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README eg
61 %{perl_vendorlib}/Filesys/DiskFree.pm
62 %{_mandir}/man3/*
63 %dir %{_examplesdir}/%{name}-%{version}
64 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.079613 seconds and 2 git commands to generate.