]> git.pld-linux.org Git - packages/perl-File-pushd.git/blob - perl-File-pushd.spec
- pl, cosmetics
[packages/perl-File-pushd.git] / perl-File-pushd.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    File
7 %define pnam    pushd
8 Summary:        File::pushd - change directory temporarily for a limited scope
9 Summary(pl.UTF-8):      File::pushd - tymczasowa zmiana katalogu dla ograniczonego kontekstu
10 Name:           perl-File-pushd
11 Version:        1.002
12 Release:        1
13 License:        Apache v2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  eac693b6968d99e0a3da89cd7babec11
17 URL:            http://search.cpan.org/dist/File-pushd/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 File::pushd does a temporary chdir that is easily and automatically
29 reverted, similar to pushd in some Unix command shells.
30
31 %description -l pl.UTF-8
32 File::pushd dokonuje tymczasowej zmiany katalogu, którą można łatwo
33 cofnąć - podobnie, jak polecenie pushd w niektórych powłokach
34 uniksowych.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}
53 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes Todo
61 %{perl_vendorlib}/File/pushd.pm
62 %{_mandir}/man3/File::pushd.3pm*
63 %{_examplesdir}/%{name}-%{version}
This page took 0.083566 seconds and 3 git commands to generate.