]> git.pld-linux.org Git - packages/perl-File-chdir.git/blob - perl-File-chdir.spec
- explicit man files
[packages/perl-File-chdir.git] / perl-File-chdir.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    chdir
7 Summary:        File::chdir - a more sensible way to change directories
8 Summary(pl.UTF-8):      File::chdir - rozsądniejszy sposób zmiany katalogów
9 Name:           perl-File-chdir
10 Version:        0.1010
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  aacfafa4a8f13d45be67451e0f9b483e
16 URL:            https://metacpan.org/release/File-chdir
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 File::chdir module - a more sensible way to change directories.
24
25 Perl's chdir() has the unfortunate problem of being very, very, very
26 global. If any part of your program calls chdir() or if any library
27 you use calls chdir(), it changes the current working directory for
28 the whole program.
29
30 File::chdir gives you an alternative, $CWD and @CWD. These two
31 variables combine all the power of chdir(), File::Spec and Cwd.
32
33 %description -l pl.UTF-8
34 Moduł File::chdir - rozsądniejszy sposób zmiany katalogów.
35
36 Perlowa funkcja chdir() jest problematyczna, ponieważ działa bardzo,
37 bardzo, bardzo globalnie. Jeśli dowolna część programu lub dowolna
38 używana biblioteka wywoła chdir(), zmienia się bieżący katalog dla
39 całego programu.
40
41 File::chdir daje alternatywę - $CWD i @CWD. Te dwie zmienne łączą całą
42 potęgę chdir(), File::Spec i Cwd.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes
66 %{perl_vendorlib}/File/chdir.pm
67 %{_mandir}/man3/File::chdir.3pm*
This page took 0.058007 seconds and 3 git commands to generate.