]> git.pld-linux.org Git - packages/perl-File-Which.git/blob - perl-File-Which.spec
- updated BRs
[packages/perl-File-Which.git] / perl-File-Which.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    File
7 %define         pnam    Which
8 Summary:        File::Which Perl module - portable implementation of the `which' utility
9 Summary(pl.UTF-8):      Moduł Perla File::Which - przenośna implementacja programu `which'
10 Name:           perl-File-Which
11 Version:        1.18
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  554bfb36568d828fbeee64f4b9a9faa8
18 URL:            http://search.cpan.org/dist/File-Which/
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(File::Spec) >= 0.60
23 BuildRequires:  perl-Test-Simple >= 0.94
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 File::Which Perl module was created to be able to get the paths to
30 executable programs on systems under which the `which' program wasn't
31 implemented in the shell.
32
33 %description -l pl.UTF-8
34 Moduł Perla File::Which powstał, aby umożliwić znajdowanie ścieżki
35 zadanego programu w systemach, w których program `which' nie jest
36 dostępny z powłoki.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/File/Which.pm
61 %{_mandir}/man3/File::Which.3pm*
This page took 0.067589 seconds and 3 git commands to generate.