]> git.pld-linux.org Git - packages/perl-File-Sync.git/blob - perl-File-Sync.spec
rebuild with perl 5.32
[packages/perl-File-Sync.git] / perl-File-Sync.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    Sync
7 Summary:        File::Sync - Perl access to fsync() and sync() function calls
8 Summary(pl.UTF-8):      File::Sync - dostęp z Perla do funkcji fsync() i sync()
9 Name:           perl-File-Sync
10 Version:        0.11
11 Release:        12
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8bb0966ff3458699c02fde3d5c799824
17 URL:            http://search.cpan.org/dist/File-Sync/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 File::Sync module provides Perl access to fsync() and sync() function
24 calls.
25
26 %description -l pl.UTF-8
27 Moduł File::Sync umożliwia dostęp do funkcji fsync() i sync() z
28 poziomu Perla.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make} \
37         CC="%{__cc}" \
38         OPTIMIZE="%{rpmcflags}"
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_vendorarch}/File/Sync.pm
55 %dir %{perl_vendorarch}/auto/File/Sync
56 %{perl_vendorarch}/auto/File/Sync/autosplit.ix
57 %attr(755,root,root) %{perl_vendorarch}/auto/File/Sync/Sync.so
58 %{_mandir}/man3/*
This page took 0.07303 seconds and 3 git commands to generate.