]> git.pld-linux.org Git - packages/perl-File-ReadBackwards.git/blob - perl-File-ReadBackwards.spec
use generic url
[packages/perl-File-ReadBackwards.git] / perl-File-ReadBackwards.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    ReadBackwards
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        File::ReadBackwards - read a file backwards by lines
9 Summary(pl.UTF-8):      File::ReadBackwards - czytanie pliku od końca, linia po linii
10 Name:           perl-File-ReadBackwards
11 Version:        1.05
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  613d9d02de6c1d86d5fa5b8816a6b214
18 URL:            http://search.cpan.org/dist/File-ReadBackwards/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 File::ReadBackwards reads a file backwards line by line. It is simple
26 to use, memory efficient and fast. It supports both an object and a
27 tied handle interface.
28
29 %description -l pl.UTF-8
30 File::ReadBackwards czyta plik od końca, linia po linii. Jest prosty w
31 użyciu, wydajny pod względem zajętości pamięci i szybki. Obsługuje
32 zarówno interfejs obiektowy, jak i dowiązane (przez tie()) uchwyty.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/%{pdir}/*.pm
57 %{_mandir}/man3/*
This page took 0.063352 seconds and 3 git commands to generate.