]> git.pld-linux.org Git - packages/perl-File-OldSlurp.git/blob - perl-File-OldSlurp.spec
use generic url
[packages/perl-File-OldSlurp.git] / perl-File-OldSlurp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    OldSlurp
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        File::OldSlurp - single call read & write file routines; read directories
9 Summary(pl.UTF-8):      File::OldSlurp - funkcje odczytu i zapisu za jednym wywołaniem
10 Name:           perl-File-OldSlurp
11 Version:        2004.0430
12 Release:        2
13 License:        distributable (see README)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bc221d24ff6d0d591ab046e5fe6ac771
17 URL:            http://search.cpan.org/dist/File-OldSlurp/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 These are quickie routines that are meant to save a couple of lines of
25 code over and over again. They do not do anything fancy.
26
27 This module used to be called File::Slurp. Uri Guttman wrote a version
28 with more features and more speed, so David Muir Sharnoff (author of
29 this module) gave the namespace to Uri. However, this version still
30 has some merit: it is much smaller and thus if speed of complilation
31 is more important that slurping speed, and you don't need the new
32 features, then this version is still useful.
33
34 %description -l pl.UTF-8
35 Ten moduł zawiera szybkie funkcje, które mają służyć do zaoszczędzenia
36 wpisywania tych samych linii kodu wiele razy. Nie robią niczego
37 fantazyjnego.
38
39 Ten moduł nazywał się kiedyś File::Slurp. Uri Guttman napisał wersję z
40 większymi możliwościami i szybszą, więc David Muir Sharnoff (autor
41 tego modułu) oddał mu przestrzeń nazw. Jednak ta wersja nadal ma pewne
42 zalety: jest dużo mniejsza i jeśli szybkość kompilacji ma większe
43 znaczenie od szybkości pracy, a nie są potrzebne nowe możliwości, ta
44 wersja nadal ma zastosowanie.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-2004.043
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CHANGELOG README
69 %{perl_vendorlib}/File/OldSlurp.pm
70 %{_mandir}/man3/*
This page took 0.07882 seconds and 3 git commands to generate.