]> git.pld-linux.org Git - packages/perl-File-Next.git/blob - perl-File-Next.spec
55fa82b97fcaa0b829a0028d11386b35e79de513
[packages/perl-File-Next.git] / perl-File-Next.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    File
7 %define pnam    Next
8 Summary:        File::Next - File-finding iterator
9 Name:           perl-File-Next
10 Version:        1.06
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8d901b18e40c477acd18a6ea0fd7de64
17 URL:            http://search.cpan.org/dist/File-Next/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Pod
22 BuildRequires:  perl-Test-Pod-Coverage
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 File::Next is an iterator-based module for finding files. It's
29 lightweight, has no dependencies, runs under taint mode, and puts your
30 program more directly in control of file selection.
31
32 It's taken heavily from Mark Jason Dominus' excellent book "Higher
33 Order Perl" <http://hop.perl.plover.com/>.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/File/Next.pm
60 %{_mandir}/man3/*
This page took 0.045017 seconds and 2 git commands to generate.