]> git.pld-linux.org Git - packages/perl-File-FnMatch.git/blob - perl-File-FnMatch.spec
rebuild with perl 5.32
[packages/perl-File-FnMatch.git] / perl-File-FnMatch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    FnMatch
7 Summary:        File::FnMatch - simple filename and pathname matching
8 Name:           perl-File-FnMatch
9 Version:        0.02
10 Release:        3
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  22f77c20d0fb5af01a3165e2df2fe34c
15 URL:            https://metacpan.org/release/File-FnMatch/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 File::FnMatch::fnmatch() provides simple, shell-like pattern matching.
22
23 Though considerably less powerful than regular expressions, shell
24 patterns are nonetheless useful and familiar to a large audience of
25 end-users.
26
27 Other possibilities include at least FNM_CASEFOLD (compare qr//i),
28 FNM_LEADING_DIR to restrict matching to everything before the first
29 '/', FNM_FILE_NAME as a synonym for FNM_PATHNAME, and the rather more
30 exotic FNM_EXTMATCH. Consult your system documentation for details.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorarch}/File/*.pm
57 %dir %{perl_vendorarch}/auto/File/FnMatch
58 %attr(755,root,root) %{perl_vendorarch}/auto/File/FnMatch/*.so
59 %{_mandir}/man3/*
This page took 0.097863 seconds and 3 git commands to generate.