]> git.pld-linux.org Git - packages/perl-FFI-Platypus.git/blob - perl-FFI-Platypus.spec
- up to 2.05
[packages/perl-FFI-Platypus.git] / perl-FFI-Platypus.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    FFI
6 %define         pnam    Platypus
7 Summary:        FFI::Platypus - Write Perl bindings to non-Perl libraries with FFI. No XS required.
8 Name:           perl-FFI-Platypus
9 Version:        2.05
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/FFI/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  745160cd773ddf03b77a965486fbab67
16 URL:            http://search.cpan.org/dist/FFI-Platypus/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  perl-Capture-Tiny
19 BuildRequires:  perl-FFI-CheckLib
20 BuildRequires:  perl-IPC-Cmd
21 %if %{with tests}
22 BuildRequires:  perl-Test2
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Platypus is a library for creating interfaces to machine code
29 libraries written in languages like C, C++, Go, Fortran, Rust, Pascal.
30 Essentially anything that gets compiled into machine code. This
31 implementation uses libffi to accomplish this task. libffi is battle
32 tested by a number of other scripting and virtual machine languages,
33 such as Python and Ruby to serve a similar role. There are a number of
34 reasons why you might want to write an extension with Platypus instead
35 of XS:
36
37 * FFI::Platypus does not require messing with the guts of Perl
38 * FFI::Platypus is portable
39 * FFI::Platypus could be a bridge to Perl 6
40 * FFI::Platypus can be reimplemented
41 * FFI::Platypus is pure perl (sorta)
42 * FFI::Platypus is not C or C++ centric
43 * FFI::Platypus does not require a parser
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Change* README
69 %{perl_vendorarch}/FFI/Build.pm
70 %dir %{perl_vendorarch}/FFI/Build
71 %dir %{perl_vendorarch}/FFI/Build/File
72 %{perl_vendorarch}/FFI/Build/File/Base.pm
73 %{perl_vendorarch}/FFI/Build/File/C.pm
74 %{perl_vendorarch}/FFI/Build/File/CXX.pm
75 %{perl_vendorarch}/FFI/Build/File/Library.pm
76 %{perl_vendorarch}/FFI/Build/File/Object.pm
77 %{perl_vendorarch}/FFI/Build/MM.pm
78 %{perl_vendorarch}/FFI/Build/Platform.pm
79 %{perl_vendorarch}/FFI/Build/Plugin.pm
80 %{perl_vendorarch}/FFI/Build/PluginData.pm
81 %{perl_vendorarch}/FFI/Platypus.pm
82 %dir %{perl_vendorarch}/FFI/Platypus
83 %{perl_vendorarch}/FFI/Platypus/API.pm
84 %{perl_vendorarch}/FFI/Platypus/Buffer.pm
85 %{perl_vendorarch}/FFI/Platypus/Bundle.pm
86 %{perl_vendorarch}/FFI/Platypus/Closure.pm
87 %{perl_vendorarch}/FFI/Platypus/Constant.pm
88 %{perl_vendorarch}/FFI/Platypus/DL.pm
89 #%{perl_vendorarch}/FFI/Platypus/Declare.pm
90 %{perl_vendorarch}/FFI/Platypus/Function.pm
91 %{perl_vendorarch}/FFI/Platypus/Internal.pm
92 %{perl_vendorarch}/FFI/Platypus/Lang.pm
93 %dir %{perl_vendorarch}/FFI/Platypus/Lang
94 %{perl_vendorarch}/FFI/Platypus/Lang/ASM.pm
95 %{perl_vendorarch}/FFI/Platypus/Lang/C.pm
96 %{perl_vendorarch}/FFI/Platypus/Lang/Win32.pm
97 %{perl_vendorarch}/FFI/Platypus/Legacy.pm
98 %{perl_vendorarch}/FFI/Platypus/Memory.pm
99 %{perl_vendorarch}/FFI/Platypus/Record.pm
100 %dir %{perl_vendorarch}/FFI/Platypus/Record
101 %{perl_vendorarch}/FFI/Platypus/Record/Meta.pm
102 %{perl_vendorarch}/FFI/Platypus/Record/TieArray.pm
103 %{perl_vendorarch}/FFI/Platypus/ShareConfig.pm
104 %{perl_vendorarch}/FFI/Platypus/Type.pm
105 %dir %{perl_vendorarch}/FFI/Platypus/Type
106 %{perl_vendorarch}/FFI/Platypus/Type/PointerSizeBuffer.pm
107 %{perl_vendorarch}/FFI/Platypus/Type/StringArray.pm
108 %{perl_vendorarch}/FFI/Platypus/Type/StringPointer.pm
109 %{perl_vendorarch}/FFI/Platypus/Type/WideString.pm
110 %{perl_vendorarch}/FFI/Platypus/TypeParser.pm
111 %dir %{perl_vendorarch}/FFI/Platypus/TypeParser
112 %{perl_vendorarch}/FFI/Platypus/TypeParser/Version0.pm
113 %{perl_vendorarch}/FFI/Platypus/TypeParser/Version1.pm
114 %{perl_vendorarch}/FFI/Platypus/TypeParser/Version2.pm
115 %{perl_vendorarch}/FFI/Probe.pm
116 %dir %{perl_vendorarch}/FFI/Probe
117 %{perl_vendorarch}/FFI/Probe/Runner.pm
118 %dir %{perl_vendorarch}/FFI/Probe/Runner
119 %{perl_vendorarch}/FFI/Probe/Runner/Builder.pm
120 %{perl_vendorarch}/FFI/Probe/Runner/Result.pm
121 %{perl_vendorarch}/FFI/Temp.pm
122 %{perl_vendorarch}/FFI/typemap
123 %dir %{perl_vendorarch}/auto/FFI/Platypus
124 %attr(755,root,root) %{perl_vendorarch}/auto/FFI/Platypus/Platypus.so
125 %{perl_vendorarch}/auto/FFI/Platypus/Constant
126 %{perl_vendorarch}/auto/FFI/Platypus/Memory
127 %{perl_vendorarch}/auto/FFI/Platypus/Record
128 %dir %{perl_vendorarch}/auto/share/dist/FFI-Platypus
129 %{perl_vendorarch}/auto/share/dist/FFI-Platypus/config.pl
130 %dir %{perl_vendorarch}/auto/share/dist/FFI-Platypus/include
131 %{perl_vendorarch}/auto/share/dist/FFI-Platypus/include/ffi_platypus_bundle.h
132 %{perl_vendorarch}/auto/share/dist/FFI-Platypus/include/ffi_platypus_config.h
133 %dir %{perl_vendorarch}/auto/share/dist/FFI-Platypus/lib
134 %attr(755,root,root) %{perl_vendorarch}/auto/share/dist/FFI-Platypus/lib/libplfill.so
135 %dir %{perl_vendorarch}/auto/share/dist/FFI-Platypus/probe
136 %dir %{perl_vendorarch}/auto/share/dist/FFI-Platypus/probe/bin
137 %{perl_vendorarch}/auto/share/dist/FFI-Platypus/probe/bin/dlrun
138 %{perl_vendorarch}/auto/share/dist/FFI-Platypus/probe/probe.pl
139 %dir %{perl_vendorarch}/auto/share/dist/FFI-Platypus/probe/src
140 %{perl_vendorarch}/auto/share/dist/FFI-Platypus/probe/src/dlrun.c
141 %{_mandir}/man3/FFI::Build*.3pm*
142 %{_mandir}/man3/FFI::Platypus*.3pm*
143 %{_mandir}/man3/FFI::Probe*.3pm*
144 %{_mandir}/man3/FFI::Temp*.3pm*
This page took 0.119023 seconds and 3 git commands to generate.