]> git.pld-linux.org Git - packages/perl-FCGI.git/blob - perl-FCGI.spec
rebuild with perl 5.32
[packages/perl-FCGI.git] / perl-FCGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define pdir    FCGI
6 Summary:        FCGI - Fast CGI module
7 Summary(pl.UTF-8):      FCGI - szybki moduł CGI
8 Name:           perl-FCGI
9 Version:        0.78
10 Release:        7
11 License:        BSD-like
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/FCGI/FCGI-%{version}.tar.gz
14 # Source0-md5:  916cd2887b27265cd8dcfd3280135270
15 Source1:        %{name}-acinclude.m4
16 Patch0:         am.patch
17 URL:            http://search.cpan.org/dist/FCGI/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a FastCGI module for perl. It's based on the FCGI module that
26 comes with Open Market's FastCGI Developer's Kit, but does not require
27 you to recompile perl.
28
29 %description -l pl.UTF-8
30 To jest moduł FastCGI. Jest bazowany na module FCGI dostarczanym z
31 FastCGI Developer's Kit, ale nie wymaga rekompilacji Perla.
32
33 %prep
34 %setup -q -n %{pdir}-%{version}
35 %patch0 -p1
36 cp -f %{SOURCE1} acinclude.m4
37
38 %build
39 %{__aclocal}
40 %{__autoconf}
41 %configure
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 install eg/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Change* README
65 %{perl_vendorarch}/FCGI.pm
66 %dir %{perl_vendorarch}/auto/FCGI
67 %attr(755,root,root) %{perl_vendorarch}/auto/FCGI/FCGI.so
68 %{_mandir}/man3/FCGI.3pm*
69 %dir %{_examplesdir}/%{name}-%{version}
70 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.058976 seconds and 3 git commands to generate.