]> git.pld-linux.org Git - packages/perl-FCGI.git/blob - perl-FCGI.spec
37b9dd12db73d4767cf29a78d3d39ccf7954f92d
[packages/perl-FCGI.git] / perl-FCGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    FCGI
7 Summary:        FCGI - Fast CGI module
8 Summary(pl.UTF-8):      FCGI - szybki moduł CGI
9 Name:           perl-FCGI
10 Version:        0.78
11 Release:        3
12 License:        BSD-like
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/FCGI/FCGI-%{version}.tar.gz
15 # Source0-md5:  916cd2887b27265cd8dcfd3280135270
16 Source1:        %{name}-acinclude.m4
17 Patch0:         am.patch
18 URL:            http://search.cpan.org/dist/FCGI/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is a FastCGI module for perl. It's based on the FCGI module that
27 comes with Open Market's FastCGI Developer's Kit, but does not require
28 you to recompile perl.
29
30 %description -l pl.UTF-8
31 To jest moduł FastCGI. Jest bazowany na module FCGI dostarczanym z
32 FastCGI Developer's Kit, ale nie wymaga rekompilacji Perla.
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36 %patch0 -p1
37 cp -f %{SOURCE1} acinclude.m4
38
39 %build
40 %{__aclocal}
41 %{__autoconf}
42 %configure
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 install eg/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Change* README
66 %{perl_vendorarch}/FCGI.pm
67 %dir %{perl_vendorarch}/auto/FCGI
68 %attr(755,root,root) %{perl_vendorarch}/auto/FCGI/FCGI.so
69 %{_mandir}/man3/FCGI.3pm*
70 %dir %{_examplesdir}/%{name}-%{version}
71 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.045992 seconds and 2 git commands to generate.