]> git.pld-linux.org Git - packages/perl-ExtUtils-TBone.git/blob - perl-ExtUtils-TBone.spec
use generic url
[packages/perl-ExtUtils-TBone.git] / perl-ExtUtils-TBone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    ExtUtils
6 %define         pnam    TBone
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        ExtUtils::TBone - a "skeleton" for writing test files
9 Summary(pl.UTF-8):      ExtUtils::TBone - szkielet do tworzenia testów
10 Name:           perl-ExtUtils-TBone
11 Version:        1.124
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  81914cadf266f6cd2083bd321c1557cd
18 URL:            http://search.cpan.org/dist/ExtUtils-TBone/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ExtUtils::TBone Perl module is intended for folks who release CPAN
26 modules with "t/*.t" tests. It makes it easy for you to output
27 syntactically correct test-output while at the same time logging all
28 test activity to a log file. Hopefully, bug reports which include the
29 contents of this file will be easier for you to investigate.
30
31 %description -l pl.UTF-8
32 Moduł Perla ExtUtils::TBone jest przeznaczony dla autorów modułów CPAN
33 zawierających testy "t/*.t". Upraszcza on tworzenie poprawnego
34 składniowo wyjścia testów, przy jednoczesnym logowaniu wszelkiej
35 aktywności danego testu. Raporty o błędach zawierające ten log powinny
36 być łatwiejsze do zbadania.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README docs/*
60 %{perl_vendorlib}/ExtUtils/TBone.pm
61 %{_mandir}/man3/*
This page took 0.062598 seconds and 3 git commands to generate.