]> git.pld-linux.org Git - packages/perl-ExtUtils-ParseXS.git/blob - perl-ExtUtils-ParseXS.spec
91b9bcd4eec72737b6b7b3fd6081414da585d66c
[packages/perl-ExtUtils-ParseXS.git] / perl-ExtUtils-ParseXS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    ExtUtils
7 %define pnam    ParseXS
8 Summary:        ExtUtils::ParseXS - converts Perl XS code into C code
9 Summary(pl.UTF-8):      ExtUtils::ParseXS - przekształcanie kodu Perl XS do C
10 Name:           perl-ExtUtils-ParseXS
11 Version:        3.24
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  e6be3f1d493e04ed805576104cf4328b
19 URL:            http://search.cpan.org/dist/ExtUtils-ParseXS/
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.46
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-ExtUtils-CBuilder
25 BuildRequires:  perl-Test-Simple >= 0.47
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ExtUtils::ParseXS will compile XS code into C code by embedding the
32 constructs necessary to let C functions manipulate Perl values and
33 creates the glue necessary to let Perl access those functions. The
34 compiler uses typemaps to determine how to map C function parameters
35 and variables to Perl values.
36
37 %description -l pl.UTF-8
38 ExtUtils::ParseXS kompiluje kod XS do kodu C osadzając konstrukcje
39 umożliwiające funkcjom w C operowanie na wartościach perlowych, a
40 także tworzy kod sklejający umożliwiający Perlowi dostęp do tych
41 funkcji. Kompilator wykorzystuje plik typemaps do określenia sposobu
42 odwzorowywania parametrów funkcji i zmiennych C na wartości perlowe.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/ExtUtils/ParseXS.pod
61 # in perl-devel-tools
62 %{__rm} $RPM_BUILD_ROOT%{_bindir}/xsubpp \
63         $RPM_BUILD_ROOT%{_mandir}/man1/xsubpp.1p
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/ExtUtils/ParseXS.pm
72 %{perl_vendorlib}/ExtUtils/ParseXS
73 %{perl_vendorlib}/ExtUtils/Typemaps.pm
74 %{perl_vendorlib}/ExtUtils/Typemaps
75 %{perl_vendorlib}/ExtUtils/xsubpp
76 %{_mandir}/man3/ExtUtils::ParseXS*.3pm*
77 %{_mandir}/man3/ExtUtils::Typemaps*.3pm*
This page took 0.045642 seconds and 2 git commands to generate.