]> git.pld-linux.org Git - packages/perl-ExtUtils-ParseXS.git/blob - perl-ExtUtils-ParseXS.spec
- updated to 3.15
[packages/perl-ExtUtils-ParseXS.git] / perl-ExtUtils-ParseXS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    ExtUtils
7 %define pnam    ParseXS
8 Summary:        ExtUtils::ParseXS - converts Perl XS code into C code
9 Summary(pl.UTF-8):      ExtUtils::ParseXS - przekształcanie kodu Perl XS do C
10 Name:           perl-ExtUtils-ParseXS
11 Version:        3.15
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  528bb055757baef1d7dd245d086e429e
19 URL:            http://search.cpan.org/dist/ExtUtils-ParseXS/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-ExtUtils-CBuilder
24 BuildRequires:  perl-Test-Simple >= 0.47
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 ExtUtils::ParseXS will compile XS code into C code by embedding the
31 constructs necessary to let C functions manipulate Perl values and
32 creates the glue necessary to let Perl access those functions. The
33 compiler uses typemaps to determine how to map C function parameters
34 and variables to Perl values.
35
36 %description -l pl.UTF-8
37 ExtUtils::ParseXS kompiluje kod XS do kodu C osadzając konstrukcje
38 umożliwiające funkcjom w C operowanie na wartościach perlowych, a
39 także tworzy kod sklejający umożliwiający Perlowi dostęp do tych
40 funkcji. Kompilator wykorzystuje plik typemaps do określenia sposobu
41 odwzorowywania parametrów funkcji i zmiennych C na wartości perlowe.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/ExtUtils/ParseXS.pod
60 # in perl-devel-tools
61 %{__rm} $RPM_BUILD_ROOT%{_bindir}/xsubpp \
62         $RPM_BUILD_ROOT%{_mandir}/man1/xsubpp.1p
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes
70 %{perl_vendorlib}/ExtUtils/ParseXS.pm
71 %{perl_vendorlib}/ExtUtils/ParseXS
72 %{perl_vendorlib}/ExtUtils/Typemaps.pm
73 %{perl_vendorlib}/ExtUtils/Typemaps
74 %{perl_vendorlib}/ExtUtils/xsubpp
75 %{_mandir}/man3/ExtUtils::ParseXS*.3pm*
76 %{_mandir}/man3/ExtUtils::Typemaps*.3pm*
This page took 0.065148 seconds and 3 git commands to generate.