]> git.pld-linux.org Git - packages/perl-ExtUtils-Config.git/blob - perl-ExtUtils-Config.spec
- macros for perl autodeps
[packages/perl-ExtUtils-Config.git] / perl-ExtUtils-Config.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    ExtUtils
6 %define         pnam    Config
7 Summary:        ExtUtils::Config - A wrapper for Perl's configuration
8 Summary(pl.UTF-8):      Extutils::Cofnig - obudowanie konfiguracji Perla
9 Name:           perl-ExtUtils-Config
10 Version:        0.008
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  565a7b09c7cac5907a25bbe2c959a717
17 URL:            https://metacpan.org/release/ExtUtils-Config
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ExtUtils::Config is an abstraction around the %Config hash.
26
27 %description -l pl.UTF-8
28 ExtUtils::Config to abstrakcja wokół tablicy asocjacyjnej %Config.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make}
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} pure_install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes README
52 %{perl_vendorlib}/ExtUtils/Config.pm
53 %{_mandir}/man3/ExtUtils::Config.3pm*
This page took 0.060992 seconds and 3 git commands to generate.