]> git.pld-linux.org Git - packages/perl-ExtUtils-CBuilder.git/blob - perl-ExtUtils-CBuilder.spec
- macros for perl autodeps
[packages/perl-ExtUtils-CBuilder.git] / perl-ExtUtils-CBuilder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    ExtUtils
6 %define pnam    CBuilder
7 Summary:        ExtUtils::CBuilder - Compile and link C code for Perl modules
8 Summary(pl.UTF-8):      EXtUtils::CBuilder - kompilowanie i linkowanie kodu C dla modułów Perla
9 Name:           perl-ExtUtils-CBuilder
10 Version:        0.280230
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cf12adecda91703057e5b10e0898aeb6
17 URL:            https://metacpan.org/release/ExtUtils-CBuilder
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Perl-OSType >= 1
24 BuildRequires:  perl-Test-Simple >= 0.47
25 BuildRequires:  perl(File::Spec) >= 3.13
26 %endif
27 Requires:       perl-Perl-OSType >= 1
28 Requires:       perl(File::Spec) >= 3.13
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module can build the C portions of Perl modules by invoking the
34 appropriate compilers and linkers in a cross-platform manner. It was
35 motivated by the Module::Build project, but may be useful for other
36 purposes as well. However, it is not intended as a general
37 cross-platform interface to all your C building needs. That would have
38 been a much more ambitious goal!
39
40 %description -l pl.UTF-8
41 Ten moduł potrafi budować części modułów perlowych napisane w C
42 wywołując odpowiednie kompilatory i linkery w sposób wieloplatformowy.
43 Powstał z myślą o projekcie Module::Build, ale może być przydatny
44 także do innych celów. Nie jest jednak przeznaczony do używania jako
45 ogólny wieloplatformowy interfejs do wszelkich potrzeb budowania
46 programów w C. To byłby zbyt ambitny cel.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/ExtUtils/CBuilder.pm
71 %{perl_vendorlib}/ExtUtils/CBuilder
72 %{_mandir}/man3/ExtUtils::CBuilder*.3pm*
This page took 0.097966 seconds and 3 git commands to generate.