]> git.pld-linux.org Git - packages/perl-Exception-Class-TryCatch.git/blob - perl-Exception-Class-TryCatch.spec
use generic url
[packages/perl-Exception-Class-TryCatch.git] / perl-Exception-Class-TryCatch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Exception
6 %define         pnam    Class-TryCatch
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Exception::Class::TryCatch - syntactic try/catch sugar for use with Exception::Class
9 Summary(pl.UTF-8):      Exception::Class::TryCatch - składniowe try/catch do używania z Exception::Class
10 Name:           perl-Exception-Class-TryCatch
11 Version:        1.12
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d9943ce5e251437312a11001b9531f43
18 URL:            http://search.cpan.org/dist/Exception-Class-TryCatch/
19 BuildRequires:  perl-Exception-Class >= 1.20
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Exception::Class::TryCatch - syntactic try/catch sugar for use with
27 Exception::Class.
28
29 %description -l pl.UTF-8
30 Exception::Class::TryCatch - składniowe try/catch do używania z
31 Exception::Class.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README Changes LICENSE
55 %{perl_vendorlib}/Exception
56 %{_mandir}/man3/*
This page took 0.083091 seconds and 3 git commands to generate.