]> git.pld-linux.org Git - packages/perl-Event-Lib.git/blob - perl-Event-Lib.spec
- rebuild with perl 5.30.0
[packages/perl-Event-Lib.git] / perl-Event-Lib.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4
5 %define pdir    Event
6 %define pnam    Lib
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Event::Lib - Perl extentions for event-based programming
9 Summary(pl.UTF-8):      Event::Lib - rozszerzenie Perla dla programowania opertego na zdarzeniach
10 Name:           perl-Event-Lib
11 Version:        1.04
12 Release:        7
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 #Source0:       http://www.cpan.org/modules/by-module/Event/%{pdir}-%{pnam}-%{version}.tar.gz
16 Source0:        http://search.cpan.org/CPAN/authors/id/C/CR/CRUX/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  38bc3b6b9bf44740275dad9198e702fc
18 #URL:           http://search.cpan.org/dist/Event-Lib/
19 URL:            http://search.cpan.org/~crux/Event-Lib/
20 Patch0:         libevent-2.1.patch
21 BuildRequires:  libevent-devel
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-dirs >= 2.1-16
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is a Perl wrapper around libevent(3) as available from
29 <http://www.monkey.org/~provos/libevent/>. It allows to execute a
30 function whenever a given event on a filehandle happens, a timeout
31 occurs or a signal is received.
32
33 Under the hood, one of the available mechanisms for asynchronously
34 dealing with events is used. This could be select, poll, epoll,
35 devpoll or kqueue. The idea is that you don't have to worry about
36 those details and the various interfaces they offer. Event::Lib offers
37 a unified interface to all of them.
38
39 %description -l pl.UTF-8
40 Moduł ten jest perlowym opakowaniem biblioteki libevent(3) dostępnej
41 pod adresem <http://www.monkey.org/~provos/libevent/>. Pozwala na
42 wywołanie funkcji w przypadku określonego zdarzenia na uchwycie pliku,
43 upłynięcia limitu czasu lub odebrania sygnału.
44
45 Wewnątrz używany jest jeden z dostępnych mechanizmów do
46 asynchronicznej obsługi zdarzeń - może to być select, poll, epoll,
47 devpoll lub kqueue. Idea jest taka, że programista nie musi martwić
48 się o szczegóły związane z każdym z tych interfejsów. Event::Lib
49 oferuje ujednolicony interfejs do nich wszystkich.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 %patch0 -p1
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make} \
59         CC="%{__cc}" \
60         OPTIMIZE="%{rpmcflags}"
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorarch}/Event/Lib.pm
77 %dir %{perl_vendorarch}/auto/Event/Lib
78 %attr(755,root,root) %{perl_vendorarch}/auto/Event/Lib/Lib.so
79 %{_mandir}/man3/Event::Lib.3pm*
This page took 0.101134 seconds and 3 git commands to generate.