]> git.pld-linux.org Git - packages/perl-Email-Valid.git/blob - perl-Email-Valid.spec
use generic url
[packages/perl-Email-Valid.git] / perl-Email-Valid.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Email
6 %define         pnam    Valid
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Email::Valid - module determines whether an email address is valid
9 Summary(pl.UTF-8):      Email::Valid - moduł sprawdzający poprawność adresu e-mail
10 Name:           perl-Email-Valid
11 Version:        0.187
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  190b9293fde117c7f8ce30058c79745f
18 URL:            http://search.cpan.org/dist/Email-Valid/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 %if %{with tests}
21 BuildRequires:  perl-MailTools
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module determines whether an email address is well-formed, and
29 optionally, whether a mail host exists for the domain.
30
31 %description -l pl.UTF-8
32 Ten moduł sprawdza czy adres e-mail jest poprawnie zapisany i,
33 opcjonalnie, czy istnieje host przyjmujący pocztę.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/Email/*.pm
58 %{_mandir}/man3/*
This page took 0.076541 seconds and 3 git commands to generate.