]> git.pld-linux.org Git - packages/perl-Dist-CheckConflicts.git/blob - perl-Dist-CheckConflicts.spec
- updated to 0.06
[packages/perl-Dist-CheckConflicts.git] / perl-Dist-CheckConflicts.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Dist
6 %define         pnam    CheckConflicts
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Dist::CheckConflicts - declare version conflicts for your dist
9 Summary(pl.UTF-8):      Dist::CheckConflicts - deklarowanie wersji będących w konflikcie z pakietem
10 Name:           perl-Dist-CheckConflicts
11 Version:        0.06
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/D/DO/DOY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  510193204fb24e24779e86b490b2d713
18 URL:            http://search.cpan.org/dist/Dist-CheckConflicts/
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
20 BuildRequires:  perl-devel >= 1:5.8.1
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-List-MoreUtils >= 0.12
24 BuildRequires:  perl-Sub-Exporter
25 BuildRequires:  perl-Test-Fatal
26 BuildRequires:  perl-Test-Simple >= 0.88
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 One shortcoming of the CPAN clients that currently exist is that they
33 have no way of specifying conflicting downstream dependencies of
34 modules. This module attempts to work around this issue by allowing
35 you to specify conflicting versions of modules separately, and deal
36 with them after the module is done installing.
37
38 For instance, say you have a module Foo, and some other module Bar
39 uses Foo. If Foo were to change its API in a non-backwards-compatible
40 way, this would cause Bar to break until it is updated to use the new
41 API. Foo can't just depend on the fixed version of Bar, because this
42 will cause a circular dependency (because Bar is already depending on
43 Foo), and this doesn't express intent properly anyway - Foo doesn't
44 use Bar at all. The ideal solution would be for there to be a way to
45 specify conflicting versions of modules in a way that would let CPAN
46 clients update conflicting modules automatically after an existing
47 module is upgraded, but until that happens, this module will allow
48 users to do this manually.
49
50 %description -l pl.UTF-8
51 Jednym z obecnych niedociągnięć klientów CPAN jest to, że nie ma
52 sposobu określenia zależności będących w konflikcie z modułami.
53 Niniejszy moduł próbuje obejść ten problem pozwalając określić
54 osobno wersje modułów będących w konflikcie i obsłużenie ich po
55 zainstalowaniu modułu.
56
57 Na przykład: mamy moduł Foo, a inny moduł Bar używa Foo. Jeśli Foo
58 zmieni swoje API bez kompatybilności wstecznej, spowoduje to zepsucie
59 Bar do jego uaktualnienia pod kątem nowego API. Foo nie może
60 zwyczajnie zależeć od poprawionej wersji Bar, bo spowodowałoby to
61 zależność cykliczną (ponieważ Bar już zależy od Foo) i nie wyraża
62 właściwie intencji - Foo w ogóle nie używa Bar. Idealnym rozwiązaniem
63 byłoby zapewnienie sposobu określania wersji modułów będących w
64 konflikcie w sposób pozwalający klientom CPAN na automatyczne
65 uaktualnienie będących w konflikcie modułów po uaktualnieniu
66 istniejącego modułu - ale zanim to nastąpi, ten moduł pozwala
67 użytkownikom uczynić to ręcznie.
68
69 %prep
70 %setup -q -n %{pdir}-%{pnam}-%{version}
71
72 %build
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor
75 %{__make}
76
77 %{?with_tests:%{__make} test}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} pure_install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc Changes README
91 %dir %{perl_vendorlib}/Dist
92 %{perl_vendorlib}/Dist/CheckConflicts.pm
93 %{_mandir}/man3/Dist::CheckConflicts.3pm*
This page took 0.089933 seconds and 3 git commands to generate.