]> git.pld-linux.org Git - packages/perl-Digest.git/blob - perl-Digest.spec
use generic url
[packages/perl-Digest.git] / perl-Digest.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Digest
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Digest - Perl modules that calculate message digests
8 Summary(pl.UTF-8):      Digest - moduły do obliczania skrótów komunikatów
9 Name:           perl-Digest
10 Version:        1.17
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  2f8a38f7f6c1bd2df36feb16d8208d6d
17 URL:            http://search.cpan.org/dist/Digest/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is just a simple frontend module for autoloading of various
25 Digest:: modules. It also provide documentation of the interface that
26 all Digest:: modules should provide.
27
28 %description -l pl.UTF-8
29 Ten moduł jest prostym frontendem do automatycznego wczytywania
30 różnych modułów Digest::. Zawiera także dokumentację do interfejsu
31 ogólnego dla wszystkich modułów Digest::.
32
33 %prep
34 %setup -q -n %{pdir}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40 %{?with_tests: %{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_vendorlib}/Digest.pm
55 %{perl_vendorlib}/Digest/*
56 %{_mandir}/man3/*
This page took 0.087823 seconds and 3 git commands to generate.