]> git.pld-linux.org Git - packages/perl-Digest-Whirlpool.git/blob - perl-Digest-Whirlpool.spec
- release 6 (by relup.sh)
[packages/perl-Digest-Whirlpool.git] / perl-Digest-Whirlpool.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Digest
7 %define pnam    Whirlpool
8 Summary:        Digest::Whirlpool - A 512-bit, collision-resistant, one-way hash function
9 #Summary(pl.UTF-8):     
10 Name:           perl-Digest-Whirlpool
11 Version:        1.09
12 Release:        6
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  852a7672ef11d46b229c0be77330e991
18 URL:            http://search.cpan.org/dist/Digest-Whirlpool/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides an interface to the WHIRLPOOL hash algorithm. This module
25 subclasses Digest::base and can be used either directly or through
26 the Digest meta-module. Using the latter is recommended.
27
28 # %description -l pl.UTF-8
29 # TODO
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make} \
38         CC="%{__cc}" \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %attr(755,root,root) %{_bindir}/*
56 %{perl_vendorarch}/Digest/*.pm
57 %dir %{perl_vendorarch}/auto/Digest/Whirlpool
58 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/Whirlpool/*.so
59 %{_mandir}/man?/*
This page took 0.117922 seconds and 3 git commands to generate.